This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] Error: Device ... could not be connected. Hotplugscripts

To: "Nick Couchman" <Nick.Couchman@xxxxxxxxx>, <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-users] Error: Device ... could not be connected. Hotplugscripts not working.
From: "Jamie Moore" <jmoore@xxxxxxxxxx>
Date: Fri, 16 Dec 2005 16:14:44 -0500
Delivery-date: Fri, 16 Dec 2005 21:17:02 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcYChS2hNrfsrJNiQ5WXMRIDFAV/UAAACiLA
Thread-topic: [Xen-users] Error: Device ... could not be connected. Hotplugscripts not working.
I got this same error but only when I set a Dom0 memory limit in the
host grup config (i.e. dom0_mem=...) I had mine set to 131072. I never
tried a different value but always when I had that one I got this error.
When I removed that it went away and the guest Nic booted fine. Not sure
if this is the same problem you have but it could be related and
possibly this points you somewhere :)

Jamie Moore

-----Original Message-----
From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
[mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Nick
Sent: Friday, December 16, 2005 1:10 PM
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Error: Device ... could not be connected.
Hotplugscripts not working.

Well, it feels like I've been very needy lately, but I'm getting very
frustrated trying to get Xen 3 to work.  My latest problem is errors
connecting devices.  If I have a network card present in my domU
configuration, I get the following error message on the command line:

Error: Device 0 (vif) could not be connected. Hotplug scripts not

If I set the configuration so that there are no NICs in the domU, I
receive the following error message, instead:

Error: Device 769 (vbd) could not be connected. Hotplug scripts not

I have tried adding lines to the /etc/xen/scripts/block script (and
other scripts) to debug it, including redirecting stderr output to
another file, but I don't get anything logged in the file.  There is
nothing to do with either udev or hotplug in my /var/log/messages file. 
I have udev 068, so the Xen installer installed the files necessary for
using udev instead of hotplug.  I've verified that the udev rule file is
installed in the correct place, and udevd is running:

xen-server00:~ # ps -ef | grep udev
root      4384     1  0 13:58 ?        00:00:00 /sbin/udevd --daemon

I've been through the list archives - both the user list and the
developer list - looking for solutions, but none of the postings seem to
apply to my situation, or at least trying the suggestions in those
posting haven't gotten me anywhere.  I'm running a clean, lean install
of SuSE10.  I didn't install the SuSE RPM's for XEN, I downloaded the
XEN source and built everything from source.  Right now the only thing
I'm trying to run is the simple ttylinux image provided on the XEN site
for testing.  I've attached the files xend.log, xend-debug.log,
xend.trace (bzipped), and the domain configuration file (ttylinux).  Can
someone point out what in the world I'm missing that's causing this

Also, I've verified that I have the necessary packages installed. 
bridge-utils is installed, and a quick glance at both "brctl show" and
"ifconfig -a" show the the ethernet interfaces are being connected.  The
problems with the vbd seem to indicate that this isn't limited to
networking, though.


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>