This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Re: is my initramdisk right? also getting 'Error opening

To: Two KHz <twokhz@xxxxxxxxx>, Xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Re: is my initramdisk right? also getting 'Error opening /dev/console' error
From: Jayesh Salvi <jayeshsalvi@xxxxxxxxx>
Date: Wed, 14 Dec 2005 21:39:04 +1800
Delivery-date: Wed, 14 Dec 2005 03:40:55 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; b=Eaz/S2WDD4uev3eB3iADjFZoMiKFTO+b10oq62X1iXfWQP1o6GyU5R7/5GHgxTfQZg0uKJygFmfI6lNAXFWBsCYkdwA56KeMtXTTphIVatXGYSkINybrxXCBLpgTg83BXzcQu93LW5fWmfAMiD8Yr8cjCeXzKtEA9Qq1fUe0+e4=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <69641da20512131404w7cd5936dt539ad6a4106ef319@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <871640aa0512122247o3ffd56fck629265c09742234d@xxxxxxxxxxxxxx> <69641da20512131238x293ea30dy85aee209590f875d@xxxxxxxxxxxxxx> <69641da20512131240p787205a8yaac9da649a74c472@xxxxxxxxxxxxxx> <871640aa0512131247w4141466bye181a3dce751525e@xxxxxxxxxxxxxx> <69641da20512131311i2c975f3ar38fcd29a5df531db@xxxxxxxxxxxxxx> <871640aa0512131321u6ed897c4oc09bfa040f6e7f4@xxxxxxxxxxxxxx> <871640aa0512131330r1a97f3faqceac78f36af437a@xxxxxxxxxxxxxx> <69641da20512131341q11ca7a9epac89e52a24d85c95@xxxxxxxxxxxxxx> <871640aa0512131350h5485d353r2ae37f8f56dbba29@xxxxxxxxxxxxxx> <69641da20512131404w7cd5936dt539ad6a4106ef319@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Yeah it worked. I installed Fedora Core 4 minimal installation on a /dev/hda9. And then it worked.


On 12/14/05, Two KHz < twokhz@xxxxxxxxx> wrote:
Great, all the best......

On 12/14/05, Jayesh Salvi <jayeshsalvi@xxxxxxxxx > wrote:
LMK is "Let Me Know" :)

Thanks for your patience. I will install right distro on hda9 after I go home tonight and let u know.

Thanks again,


On 12/13/05, Two KHz <twokhz@xxxxxxxxx> wrote:
Oh my god!!!!!!!!.........,
it is indeed silly.....
Anyways, we all learn by making mistakes......

Yes, you need to have a distro installed in your hda9 partition., you can just copy your dom0 distro into your hda9. or else  mount any distro (complete "/")of other machine thru NFS and copy that into hda9, and make appropriate changes to fstab file in your new hda9 partition.

dont make any other changes to grub or mydomain conf file.

and that should boot your VM beautyfully...
believe me, trust me.. Xen is amazing to work on.

WELCOME to Xen!!!!

btw, whats LMK that you mention in your signature...


On 12/14/05, Jayesh Salvi <jayeshsalvi@xxxxxxxxx > wrote:
A friend of mine just told me that I should have installed some disto of linux on the /dev/hda9. Is that it then? Very silly mistake I guess :(

LMK twokhz what u think.

On 12/13/05, Jayesh Salvi <jayeshsalvi@xxxxxxxxx> wrote:
The /etc/fstab on my dom0's root partition looks like:
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/                 /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/hda7               swap                    swap    defaults        0 0
/dev/hdc                /media/cdrecorder2      auto    pamconsole,exec,noauto,managed 0 0

But I don't have anything on the /dev/hda9 partition. I had formatted it clean, installed ext3. There is no /etc directory there. I didn't know what files should I have on this /dev/hda9 (domU's root) [ Is that the silly mistake I have made?]. I only created /dev there manually to skip the /dev/device error.

Let me know.

Sorry if it turns out to be very silly mistake.


On 12/13/05, Two KHz < twokhz@xxxxxxxxx> wrote:
Ok, now this is serious issue..
I am loosing my patience now...
can you give me your fstab file in /etc

and mount your /dev/hda9 and provide me the fstab file from that mounted partition.

let me see whats the issue.

On 12/14/05, Jayesh Salvi <jayeshsalvi@xxxxxxxxx > wrote:
I created initrd using the command
# mkinitrd -v -f --with=sd_mod --with=scsi_mod initrd-

Now let me try running it without using initrd.

ok, I get this:
xm create -c mydomain vmid=1
Using config file "/etc/xen/mydomain".
Started domain MyDomain
Linux version (root@Machine) (gcc version 4.0.1 20050727 (Red Hat 4.0.1-5)) #2 SMP Sat Dec 10 20:19:56 CST 2005
BIOS-provided physical RAM map:
 Xen: 0000000000000000 - 0000000004000000 (usable)
0MB HIGHMEM available.
72MB LOWMEM available.
IRQ lockup detection disabled
Built 1 zonelists
Kernel command line:  root=/dev/hda9 ro 4
Initializing CPU#0
PID hash table entries: 512 (order: 9, 8192 bytes)
Xen reported: 1295.793 MHz processor.
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
vmalloc area: c5000000-fb7fe000, maxmem 34000000
Memory: 61636k/73728k available (1817k kernel code, 3752k reserved, 478k data, 136k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Mount-cache hash table entries: 512
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... disabled
Brought up 1 CPUs
NET: Registered protocol family 16
Brought up 1 CPUs
xen_mem: Initialising balloon driver.
Grant table initialized
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Xen virtual console successfully installed as tty1
Event-channel device installed.
netfront: Initialising virtual ethernet driver.
NET: Registered protocol family 2
Registering block device major 3
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP established hash table entries: 4096 (order: 3, 32768 bytes)
TCP bind hash table entries: 4096 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 4096 bind 4096)
NET: Registered protocol family 1
NET: Registered protocol family 17
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 136k freed
Warning: unable to open an initial console.
Kernel panic - not syncing: No init found.  Try passing init= option to kernel.

Any idea what init option is it looking for?

Thanks for your suggestions so far.


On 12/13/05, Two KHz < twokhz@xxxxxxxxx> wrote:
moreover, line:
Switching to new root
shows that it was using intrd and then trying to switch to the new root from the harddrive,, but because of some issues in initrd's root, its not able to switch properly

On 12/14/05, Two KHz <twokhz@xxxxxxxxx> wrote:
How was initrd for domU created. you ussually dont need that initrd for a domU because you are not using any scsi harddrives here.
try to remove ramdisk=***in mydomain.

I believe you dont need all these...
Loading scsi_mod.ko module
SCSI subsystem initialized
Loading sd_mod.ko module

these i believe are from initrd.

I donno what this error means
WARNING: can't access (null)
exec of init ((null)) failed!!!: 14

But looking at your boot messages.......
Switching to new root
ERROR opening /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1

I think all these errors are due to initrd of Dom0 being used in DomU

Just remove ramdisk line and hope for the best...


On 12/14/05, Jayesh Salvi <jayeshsalvi@xxxxxxxxx > wrote:
Just tried that. That didn't work either :(

Still getting same errors.


On 12/13/05, Two KHz < twokhz@xxxxxxxxx> wrote:
Can you just try changing the following line in mydomain
disk = [ 'phy:hda9,hda9,w' ]
disk = [ 'phy:/dev/hda9,hda9,w' ]








Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>