This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Solved: network problems when starting xend, Xen-3.0 + tg3

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Solved: network problems when starting xend, Xen-3.0 + tg3
From: "Woon Wai Keen @ doubleukay.com" <doubleukay@xxxxxxxxxxxxxx>
Date: Sun, 11 Dec 2005 04:01:17 +0800
Delivery-date: Sun, 11 Dec 2005 01:25:34 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 1.0.7 (Windows/20050923)
I finally found out why the network became unreachable (to the point that tcpdump -i peth0 revealed no packets) when xend is started. This is triggered when the tg3 interface is added to a bridge before the link comes up.

The message displayed on the console is:
        bridge: can't decode speed from peth0: 0.

In scripts/network-bridge, the order of the operations are:
        add_to_bridge ${bridge} ${vif0}
        add_to_bridge ${bridge} ${pdev}
        ip link set ${bridge} up
        ip link set ${vif0} up
        ip link set ${pdev} up

What worked for me is:
        ip link set ${bridge} up
        ip link set ${vif0} up
        ip link set ${pdev} up
        sleep 5 # to allow for autonegotiation period
        add_to_bridge ${bridge} ${vif0}
        add_to_bridge ${bridge} ${pdev}

The problem persists when forcing the link speed and disabling auto-neg with ethtool.

Is this a bug with the tg3 driver or the bridging code?

wK (www.doubleukay.com)

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>