This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: problem running xend

To: Xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Re: problem running xend
From: Jayesh Salvi <jayeshsalvi@xxxxxxxxx>
Date: Sun, 11 Dec 2005 11:17:23 +1800
Delivery-date: Sat, 10 Dec 2005 17:18:41 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; b=lkLTS/ordvHDR0h8MEgMCdRXGR2X2y4jAFhP1tQ1X9gDxCrELrksrHYlCqTKKh+ZBt+DS4QR/TyjwWV1sk3BlPdTFkuceHM1RQKHDd2bRVLKhT61YNSPkgH1s/kYLOD8oy+i5Ry3cDVrcn5ypLIAS7nYtluaxhay7nnIdGHBxko=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <871640aa0512092138w4e35b5c1l171065bc183b7854@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <871640aa0512092138w4e35b5c1l171065bc183b7854@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Doing ldd on xs.so shows:
[jayesh@orion xen]$ ldd /usr/lib/python2.4/site-packages/xen/lowlevel/xs.so
        linux-gate.so.1 =>  (0xfbffd000)
        libxc.so.3.0 => /usr/lib/libxc.so.3.0 (0xb7ec4000)
        libxenstore.so => /usr/lib/libxenstore.so (0xb7ebd000)
        libpthread.so.0 => /lib/i686/nosegneg/libpthread.so.0 (0xb7eab000)
        libc.so.6 => /lib/i686/nosegneg/libc.so.6 (0xb7d7e000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb7d6b000)
        /lib/ld-linux.so.2 (0x80000000)

So I tried to search xs_shutdown symbol in libxenstore.so as that seems to be the only file to have come from xen installation.

[jayesh@orion xen]$ nm /usr/lib/libxenstore.so | grep xs
00002d30 T xs_count_strings
00001540 T xs_daemon_close
000014e0 T xs_daemon_open
00001500 T xs_daemon_open_readonly
00002d70 T xs_daemon_socket
00002a50 T xs_daemon_socket_ro
000029f0 T xs_daemon_tdb
00001d10 T xs_debug_command
00003200 d xsd_errors
00002400 T xs_directory
00002b10 T xs_domain_dev
00001520 T xs_domain_open
00001690 T xs_fileno
00002390 T xs_get_domain_path
00002550 T xs_get_permissions
00001d70 T xs_introduce_domain
00002040 T xs_is_domain_introduced
000021a0 T xs_mkdir
00002ca0 T xs_perm_to_string
00002150 T xs_read
00002800 T xs_read_watch
000020d0 T xs_release_domain
00002210 T xs_rm
00002640 T xs_set_permissions
00002bb0 T xs_strings_to_perms
000019c0 t xs_talkv
         U __xstat@@GLIBC_2.0
00002310 T xs_transaction_end
00002280 T xs_transaction_start
00001e50 T xs_unwatch
00001ed0 T xs_watch
00001fb0 T xs_write
00002b40 T xs_write_all

But did not find xs_shutdown there.

Strangely I don't understand why there is no symbol in xs.so

[jayesh@orion xen]$ nm /usr/lib/python2.4/site-packages/xen/lowlevel/xs.so
nm: /usr/lib/python2.4/site-packages/xen/lowlevel/xs.so: no symbols

I also tried to search through the xen source tree for the symbols xs_shutdown, yet didn't find it.

Does anybody know what xs_* functions are for and where can I find xs_shutdown?


On 12/10/05, Jayesh Salvi <jayeshsalvi@xxxxxxxxx> wrote:
I successfully built and installed Xen 3.0 (with linux kernel 2.6.12). I however get following symbol resolution runtime error while trying to do 'xend start'.

[root@orion ~]# /etc/init.d/xend start
Traceback (most recent call last):
  File "/usr/sbin/xend", line 33, in ?
    from xen.xend.server import SrvDaemon
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line 31, in ?
    import controller
  File "/usr/lib/python2.4/site-packages/xen/xend/server/controller.py", line 23, in ?
    from xen.xend.xenstore import DBVar
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/__init__.py", line 17, in ?
    from xsnode import *
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xsnode.py", line 26, in ?
    from xen.lowlevel import xs
ImportError: /usr/lib/python2.4/site-packages/xen/lowlevel/xs.so: undefined symbol: xs_shutdown

Here is the version information:
gcc version 4.0.1 20050727 (Red Hat 4.0.1-5)
Zlib version: zlib-, zlib-devel-
Python: python-devel-2.4.1-2
(don't have latex)

Any idea what might be going on?



Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>