This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Re: [xen-3.4.2][] pciback not seizing devices

To: Sander Eikelenboom <linux@xxxxxxxxxxxxxx>
Subject: [Xen-devel] Re: [xen-3.4.2][] pciback not seizing devices
From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Date: Mon, 14 Dec 2009 09:54:00 -0500
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 14 Dec 2009 07:06:28 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <767436573.20091214101209@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <767436573.20091214101209@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.19 (2009-01-05)
On Mon, Dec 14, 2009 at 10:12:09AM +0100, Sander Eikelenboom wrote:
> Hi Konrad,
> I was trying pvops on my xen-3.4.2 server passing through 3 
> pci-devices, but none seems to get seized by pciback.
> On xen-3.4.2 in combination with a xenified 2.6.29 kernel/ 
> kernel it works fine with the same config in grub.
> Could this be due to the renaming stuff of blkdev pciback to xen-blkdev 
> xen-pciback etc. ?

Might be. Try to change the 'pciback.hide' to 'xen-pciback.hide' and see if that
helps you out. In the meantime I am going to try to try the same thing on my 

I usually do the unbind, new-slot, bind process.

Xen-devel mailing list