This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Breakage in -unstable for Transmeta -- Solution

To: Keir Fraser <Keir.Fraser@xxxxxxxxxxxx>
Subject: Re: [Xen-devel] Breakage in -unstable for Transmeta -- Solution
From: "Carl Holtje ;021;vcsg6;" <cwh0803@xxxxxxxxxx>
Date: Mon, 27 Jun 2005 11:55:01 -0400 (EDT)
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 27 Jun 2005 15:53:56 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <b9fe08309c645a5c71f8a5b95975fdf2@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <Pine.GSO.4.58.0506221441140.23919@xxxxxxxxxxxxxxxx> <91682d35640728e6b4e763e88bbcb465@xxxxxxxxxxxx> <Pine.GSO.4.58.0506231636120.10383@xxxxxxxxxxxxxxxx> <bd9c262c7aa8c86c6db4332f23614cc7@xxxxxxxxxxxx> <Pine.GSO.4.58.0506232019290.18321@xxxxxxxxxxxxxxxx> <fa6a51f13f61dd01134ebce891ddbe73@xxxxxxxxxxxx> <Pine.GSO.4.58.0506240859070.17433@xxxxxxxxxxxxxxxx> <193974b525123922007225148c6938fb@xxxxxxxxxxxx> <Pine.GSO.4.58.0506241153160.17433@xxxxxxxxxxxxxxxx> <50b68f3ddc1ff3db9893e0d7ad10b884@xxxxxxxxxxxx> <Pine.GSO.4.58.0506241513430.17433@xxxxxxxxxxxxxxxx> <dd37095c934ac49ee7926a4e3ee12e25@xxxxxxxxxxxx> <Pine.GSO.4.58.0506242145140.20987@xxxxxxxxxxxxxxxx> <b9fe08309c645a5c71f8a5b95975fdf2@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
On Sat, 25 Jun 2005, Keir Fraser wrote:

> On 25 Jun 2005, at 02:57, Carl Holtje ;021;vcsg6; wrote:
> > * In xen/arch/x86/boot/x86_32.S, disable FPU initialization
> > * In xen/arch/x86/boot/x86_32.S, disable PGE enabling
> > * In xen/{I don't remember}/flushtlb.c, the call to local_flush_tlb or
> > something of this nature calls __pge_off() and __pge_on -- I used a
> > #ifdef
> > CONFIG_X86_TRANSMETA to work around it as local_flush_tlb is a #define.
> > (I'm certainly not saying what I've done is best by any means, but it
> > works for me..)
> The PGE enable, and __pge_off/__pge_on, are easily handled. I'll do a
> patch for those.
> Do Transmeta CPUs really not have an FPU unit?

No, they do in fact have FPUs.. it is my understanding they are
initialized auto-magically by the CPU, and a subsequent initialization
from software totally confused the device, and it reset.

I'm workin' on a proper patch -- I'm in and out of the office all week, so
it may take me a bit..



- --

"There are 10 types of people in the world: Those who understand binary
and those that don't."

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>