This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] pae support

To: Wim Coekaerts <wim.coekaerts@xxxxxxxxxx>
Subject: Re: [Xen-devel] pae support
From: Gerd Knorr <kraxel@xxxxxxx>
Date: 24 Jun 2005 10:00:37 +0200
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 24 Jun 2005 08:04:07 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20050623203214.GD25388@xxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Organization: SUSE Labs, Berlin
References: <20050623203214.GD25388@xxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3
Wim Coekaerts <wim.coekaerts@xxxxxxxxxx> writes:

> any update on where pae support is ?  thanks :)

I'm working on it, see the patches on this list this week ;)

Dom0 boots fine finally seems to work stable for me with the tlbflush
bug pinned yesterday.  NX works too.  I'll resync with latest -bk and
upload patches later today.

Next item on my todo list is to finish the hypercall interface
changes, these really must go in before 3.0.  Patches for xen and
xenolinux are there already, tools are not updated yet.

Following work items: DomU boot in PAE mode (tools work).  Find and
fix the bugs which trigger with more than 4 GB installed.  Ideally
that should be finished before 3.0 as well so 3.0 ships with basic PAE

After that: Make shadow mode work (needed for suspend/resume and

Hope that helps,


panic("it works"); /* avoid being flooded with debug messages */

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>