This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Breakage in -unstable for Transmeta

On Thu, 23 Jun 2005, Keir Fraser wrote:

> On 22 Jun 2005, at 19:50, Carl Holtje ;021;vcsg6; wrote:
> > In xen/arch/x86/boot/x83_32.S, a great deal has changed since 2.0.6 and
> > even some recent pulls of the unstable tree. These changes have stoped
> > my
> > Transmeta efforts cold; the box now reboots upon boot..
> >
> > I've narrowed it down (at least I think I have) to the following lines
> > from the start_paging routine:
> I just diff'ed between 2.0 stable and the unstable versions of that
> file, and there are almost no code changes. Just some additions to
> support PAE (which you will not be building so will not affect you) and
> the data layout changes at the bottom of the file.
> The code that you think may be causing your problem is also identically
> present in 2.0.6 so I don't think it can be due to that.

Alright.. So where do you suggest I look to try solving this?.. I was
setting waypoints in x86_32.S by printing a character and it seems to be
that code that it broke at. Since those lines reference the page table
stuff at the bottom, I'm not entirely sure where else to poke at..

I generated a diff between what I know works (on the Transmeta) and my
most recent bk pull -- the changes seem to be more applicable to SMP than
anything else...

Thanks for your help!


- --

"There are 10 types of people in the world: Those who understand binary
and those that don't."

Xen-devel mailing list