This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] No video display, SuSE kernel-xen-

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] No video display, SuSE kernel-xen-
From: Robbie Dinn <robbie@xxxxxxxxxxxx>
Date: Tue, 14 Jun 2005 16:22:33 +0100
Cc: Gerd Knorr <kraxel@xxxxxxx>
Delivery-date: Tue, 14 Jun 2005 15:21:44 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20050614144337.GA24542@bytesex>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <42AED602.2020703@xxxxxxxxxxxx> <87vf4h12jw.fsf@xxxxxxxxxxx> <42AEE81A.6030509@xxxxxxxxxxxx> <20050614144337.GA24542@bytesex>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 0.8 (X11/20040913)
Gerd Knorr wrote:
adler:~ # dmesg | grep -i console
Console: colour VGA+ 80x25
adler:~ # cat /proc/fb
adler:~ #

Standard vga text console, also no framebuffer device active.
Hmm.  You really should see something ...

Maybe grub does something silly, so the machine comes up with
the vga in graphics instead of text mode.  What happens if you
turn off the eye-candy stuff in /boot/grub/menu.lst (comment
the gfxmenu line)?

Here is what the start of my menu.lst looks like;

  adler:~ # mount /dev/hda2 /boot
  adler:~ # head /boot/grub/menu.lst
  # Modified by YaST2. Last modification on Sat Nov 13 19:12:31 2004

  timeout 8
  default 0
  root (hd0,1)
  color white/blue black/light-gray

  ###Don't change this comment - YaST2 identifier: Original name: linux###
  adler:~ #

*** STOP PRESS ***

I just put the server machine back in the rack and when
I booted it up, the text console came up with text on it!

** boggle **

However the font was corrupt (little under lines
under all the u's and p's).

** double boggle **

Part way through the font got fixed, possibly when a new
console font got loaded.

This would normally scream flakey hardware to me,
except I have seen the black screen problem on two
different disks and 3 different mother boards (that
is two motherboard and one laptop).

I sincerely hope that I haven't been leading you folks
on a wild goose chase.

yours dazed and confused,

Robbie Dinn

Xen-devel mailing list