This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Xend won't start: attribute VIRQ_DOM_EXC

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] Xend won't start: attribute VIRQ_DOM_EXC
From: Mark Williamson <mark.williamson@xxxxxxxxxxxx>
Date: Sat, 11 Jun 2005 14:51:38 +0100
Cc: Jurgen Stroo <blurg@xxxxxxxxxxxxxxx>, Xen User <xen-user@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Sat, 11 Jun 2005 13:53:30 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <Pine.LNX.4.58.0506111458130.8380@oldserver>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <9cde8bff05061103595653268f@xxxxxxxxxxxxxx> <Pine.LNX.4.58.0506111458130.8380@oldserver>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KMail/1.8
rm -rf /usr/lib/python/xen

Then reinstall the tools.

Worked for me :-)


On Saturday 11 June 2005 14:05, Jurgen Stroo wrote:
> I'll step back to Xen stable, because of my network probs with Xen
> unstable. So I configured and compiled Xen 2.0.6, but I came to the
> following error after starting Xend:
> Exception starting xend: 'module' object has no attribute 'VIRQ_DOM_EXC'
> Traceback (most recent call last):
>   File "/usr/lib/python/xen/xend/server/SrvDaemon.py", line 302, in run
>     self.createFactories()
>   File "/usr/lib/python/xen/xend/server/SrvDaemon.py", line 317, in
> createFactories
>     self.channelF = channel.channelFactory()
>   File "/usr/lib/python/xen/xend/server/channel.py", line 217, in
> channelFactory
>     inst = ChannelFactory()
>   File "/usr/lib/python/xen/xend/server/channel.py", line 65, in __init__
>     self.bind_virq(xen.lowlevel.xc.VIRQ_DOM_EXC)
> AttributeError: 'module' object has no attribute 'VIRQ_DOM_EXC'
> Can't find anything about it, and Xen did boot actually, with Xen
> unstable, so Python should be allright.
> Jurgen
> ---------------------------------------------------------------------------
> "When a man sits with a pretty girl for an hour, it seems like a minute.
> But let him sit on a hot stove for a minute and it's longer than any hour.
> That's relativity." [A. Einstein, 1938]
> http://jurgenstroo.com
> Mercedes W123 230C 1978 (95000km)  */-&-/* Mercedes W123 300TD 1979
> (395000km)
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>