This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Xen and ReiserFS

On Thu, 2005-06-09 at 15:51 -0500, David F Barrera wrote:
> On Thu, 2005-06-09 at 21:23 +0100, Keir Fraser wrote:
> > On 9 Jun 2005, at 21:13, David F Barrera wrote:
> > 
> > > I am unable to boot Dom0 on a machine with Reiser file systems. Reiser
> > > support is built into the xen0 kernel. I have similar setup with ext3
> > > file systems working just fine, so I don't think it is a setup problem.
> > > I have tried booting with and without and initrd file, booting with the
> > > original Linux distro initrd file, etc, but nothing seems to work. I
> > > recall seeing a thread about ReiserFS on this list some time ago, but I
> > > don't remember what the resolution was. Any ideas would be appreciated.
> > 
> > The boot log hasn't got as far as looking at the rootfs when the 
> > problems start. It looks like things go bad as soon as the SCSI driver 
> > starts to run. Does the same kernel work on the same machine if you 
> > point it at an ext3 system? 
> I have two identical machines with essentially the same setup, except
> one has ext3 and the other has Reiser file systems. The same kernel
> build works on the one that has ext3. 
ReiserFS is working fine on my box, with both the current bitkeeper tree
and with last nights unstable build.  From your boot log though, it
looks like it's breaking down in the mpt scsi driver pretty badly.  Does
the other working machine also use this driver?

Paul Larson

Attachment: signature.asc
Description: This is a digitally signed message part

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>