This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Re: [uml-user] NPTL/db4 problem with FC3

To: Nils Toedtmann <user-mode-linux-user@xxxxxxxxxxxxxxxxxx>
Subject: [Xen-devel] Re: [uml-user] NPTL/db4 problem with FC3
From: Peter <p.spamcatcher@xxxxxxxxxxxxxxx>
Date: Tue, 22 Mar 2005 16:27:49 +1200
Cc: UML user list <user-mode-linux-user@xxxxxxxxxxxxxxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 23 Mar 2005 15:55:38 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1111437260.6437.26.camel@xxxxxxxxxxxxxxxxxxxxxxx>
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
References: <1111437260.6437.26.camel@xxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 0.8 (X11/20040913)
(Me Too ++: I'm running into the same issues with a non-nptl DB4 and rpm on rhel4)

And making it even more interesting:

"Red Hat Enterprise Linux 5 will no longer include support for LinuxThreads. Therefore, applications that require LinuxThreads support must be updated before they will be able to work properly on a Red Hat Enterprise Linux 5 system."

I would appreciate a description of what needs to be done in order for xen or UML to support the use of nptl inside the guest server. And any info on progress towards trying to support it.

Regards, Peter

Nils Toedtmann wrote:
This is a cross post to <xen-devel@xxxxxxxxxxxxxxxxxxxxx> and <user-

Dear lists,

Anybody successfully running cyrus-imapd in FC2/3+Xen/UML? When i tried
to run cyrus-imapd in a virtual FC3 (Xen or UML) i got lot's of

  DBERROR db4: Berkeley DB library configured to support only
               DB_PRIVATE environments
  DBERROR: dbenv->open '/var/lib/imap/db' failed: Invalid argument
  DBERROR: init() on berkeley

It turned out to be a FC specific db4 problem with non-NPTL-aware


Unfortunatly, RedHat closed this bug as WONTFIX, but it's still present
with FC3 on ARCH={xen,um}. /lib/tls and /usr/lib/tls moved away, the
LD_ASSUME_KERNEL workaround does not help, too.

So i followed the way of Radu Greab and rebuilt db4 using his patches
and specfile


It was tricky, but worked. As this is an ugly workaround (eg it bombs
with apt/yum updating) i look for a better solution.

no sig

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
User-mode-linux-user mailing list

This SF.net email is sponsored by: 2005 Windows Mobile Application Contest
Submit applications for Windows Mobile(tm)-based Pocket PCs or Smartphones
for the chance to win $25,000 and application distribution. Enter today at
Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-devel] Re: [uml-user] NPTL/db4 problem with FC3, Peter <=