This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Xen 2.0.5 - Xend doesn't start

To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Xen 2.0.5 - Xend doesn't start
From: Charles COLLIN <collin_fsb@xxxxxxxx>
Date: Sat, 19 Mar 2005 22:43:51 +0100
Delivery-date: Sat, 19 Mar 2005 21:45:03 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 1.0 (X11/20050115)

I installed today xen 2.0.5 from source (i'm running a LFS system).
This system provides python 2.4 (in /usr/lib/python2.4/).
There were no problem during compilation of Xen itself (python code was
installed to /usr/lib/python/xen/), but during compilation of dependent
packages, i've had to hack a bit:

Packages installed:

° bridge-utils-1.0.6 : build OK
° iproute2-2.6.9-050209 : build OK
° ZopeInterface-3.0.1 : build OK (at least no error message)

° Twisted-2.0.0a3 : starts the problems,
./configure finds python but doesn't
want to use it as it expects 2.3.4 -> forced using 2.4 (./configure
--with-python /usr/bin/python). it installed to

° ZopeX3-3.0.0 :
didn't know if it really was required, but installed it, in
/opt/ZopeX3 as it didn't want /usr as prefix.
Moved /opt/ZopeX3/* to /usr
(especially /opt/ZopeX3/lib/* to /usr/lib/python2.4).
still i don't like this kind of installation.

Tried to start xend: complains that it can't find the twisted package.
--> Symlinked /usr/lib/python2.4/site-packages/twisted to /usr/lib/python2.4/twisted

Retried to start xend: now complains about missing TwistedWeb package!
OK, downloaded TwistedWeb-0.5.0a3 and installed it.

Tried Again xend: complains twisted.protocols.http is deprecated in
xend/server/SrvBase.py, should use twisted.web.http

Jesus !!! Recompiled Xen tools and installed.

Now, when i start xend i get no errors messages, but apparently it doesn't start:

root@clientFSB-19:/home/charles/VIRTUALIZATION# xm list
(111, 'Connection refused')
Error: Error connecting to xend, is xend running?


root@clientFSB-19:/home/charles/VIRTUALIZATION# ps aux
root       751  0.0  0.1  3108  792 ?        S    19:55   0:00 xfrd

Any opinion about this?


SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>