This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] AGP & Binary Nvidia Drivers

To: xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] AGP & Binary Nvidia Drivers
From: Jerome Brown <jerome@xxxxxxxxxx>
Date: Mon, 07 Mar 2005 09:04:39 +1300
Delivery-date: Sun, 06 Mar 2005 20:05:14 +0000
Envelope-to: xen+James.Bulpin@xxxxxxxxxxxx
In-reply-to: <A95E2296287EAD4EB592B5DEEFCE0E9D1E33ED@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
References: <A95E2296287EAD4EB592B5DEEFCE0E9D1E33ED@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 1.0 (X11/20050119)
Ian Pratt wrote:
>>Well, I decided to start here. I removed the old driver and tried to
>>reinstall it, to be told that it requires MTRR to be enabled in the
>>kernel. (I must have accidently compiled against the wrong 
>>sources last
>>time). When I try to add this to with ARCH="xen" make menuconfig, the
>>option does not present itself. Is there a way to enable this in the
>>config, or would doing so be A Bad Thing (TM)? (I am also 
>>interested in
>>getting my soundcard going, and the ALSA sections are also not
>>displayed, but that is the next challenge!)
> What version are you using? Xen/Linux has supported MTRR in the default
> config for sometime.

I'm using xen-testing from ~ 3 March, Kernel 2.6.10, as patched by the
Xen install script. When I rung my ARCH="xen" make menuconfig I don't
get presented with these options at all, and some of the menu options
when you select them don't display anything. Is this more likely to be a
make problem?

> I've never tried sound. There's a fair chance it will just work
> providing it doesn't use ISA DMA.

Is an onboard PCI chip, so I expect it will go!

Thanks in advance

Jerome Brown
Technology Architect

P: +64  3 961-5116
M: +64 29 453 7663
F: +64  3 961-5129
E: jerome@xxxxxxxxxx
W: http://www.hub.net.nz/
O: Level 4, 818 Colombo St, Christchurch, New Zealand
S: PO Box 1879, Christchurch, New Zealand

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list