This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] openafs not supported?

To: Steven Hand <Steven.Hand@xxxxxxxxxxxx>
Subject: Re: [Xen-devel] openafs not supported?
From: Miroslav Ruda <ruda@xxxxxxxxxxx>
Date: Wed, 02 Mar 2005 16:52:37 +0100
Cc: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 04 Mar 2005 13:25:25 +0000
Envelope-to: xen+James.Bulpin@xxxxxxxxxxxx
In-reply-to: <E1D6Uwm-0002ui-00@xxxxxxxxxxxxxxxxx>
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
References: <E1D6Uwm-0002ui-00@xxxxxxxxxxxxxxxxx>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 1.0 (X11/20041206)
Steven Hand wrote:
I'm new to Xen world. As the first step I have tried to run debian stable which I'm running on my testing machine in domain 0 (no xend started yet, no virtual machines...). I'm using kernel 2.4.29, I have copied .config from my kernel tree and did "make ARCH=xen oldconfig" etc. Xen version is 2.0.4.

Xen and kernel boots OK, but I'm not able to use openafs
(1.2.11). Module libafs can be loaded, but afsd generated oops

Is someone runnign openafs with xen? Should I try 2.6 kernel or create more simple domain 0 linux and run my version in virtual machine?

We have used openafs successfully in the past (with 2.4.x kernels too).
From your somewhat vague description my best guess is that the module
you're loading is not "xen-enabled" and hence is trying to use ring 0 instructions or somesuch.

That may be source of my problem! I have compiled openafs myself, but just with option --with-linux-kernel-headers=/home/ruda/soft-local/xen-2.0/linux-2 .4.29-xen0, which may not be enough, because I didn't specified equivalent of ARCH=xen anywhere.

If someone already compiled openafs with xen kernel, could you send me suggestions what must be changed in openafs building? Looks like they create symlinks to several include directories of linux kernel, including asm->asm-i386. Would it be enough to change it to asm-xen?

Also if I want to compile openafs for -xenU kernel, I should make it somehow "xen-enabled", right?

BTW, I will experiment with arla too, because I was easily able to set ARCH=xen
in Makefiles (they just copy linux subtree, add one subdir and call "make 

Can you post the backtrace you get after the module loads? And in fact the boot output you get from Xen and XenLinux?

I'll try to do it later, I don't have serial console now.

(also: I presume openafs is known working on your configuration when not using Xen?)

Yes, this is machine I'm using for my daily work. I just tried to boot xen-enabled kernel (vmlinuz-2.4.29-xen0) instead of my linux-2.4.29.
The same root filesystem etc.

                  Mirek Ruda

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list