This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Error initializing xen_net

On Wed, 2005-03-02 at 18:52 -0600, Anthony Liguori wrote:
> This sounds like either xcs or xend is becoming unresponsive.
> I've only seen this error occur when the NETIF messages aren't being 
> delivered correctly.
> If you can reproduce this, it would be very useful to have the output of 
> xcsdump.  It'll be large so feel free to send it to me off list or post 
> it somewhere.

To answer everything at once:

1) Yes the tools are synced with the version of Xen.  I always keep them
2) I tried to look into 'how' to run xcsdump... figured it was a binary,
but I can't find it.  How do I go about getting its output?
3) Just to throw in... i've still having the xend not restarting problem
as previously reported by anothers on this list.  It will start once on
boot, then if I stop it and try to start it xfrd will start, but xend
will not.  xend.log and xend-debug.log does not show any info.
4) As far as oddities in xend-debug.log .. not sure if these are or not,
but looked interesting.


vif-route down vif=vif15.0 domain=jtb mac=aa:00:00:2a:2b:56 bridge=xen-
RTNETLINK answers: No such process
 Loaded kernel: c0100000->c04bdf84
 Init. ramdisk: c04be000->c04be000
 Phys-Mach map: c04be000->c04de000
 Page tables:   c04de000->c04e1000
 Start info:    c04e1000->c04e2000
 Boot stack:    c04e2000->c04e3000
 TOTAL:         c0000000->c0800000
 ENTRY ADDRESS: c0100000
vif-route up vif=vif56.0 domain=jtb mac=aa:00:00:71:eb:a0 bridge=xen-br0
RTNETLINK answers: No such process
recv_fe_driver_status> {'status': 1}


recv_fe_interface_connect {'tx_shmem_frame': 300741, 'rx_shmem_frame':
300740, 'handle': 0}
VirqClient.virqReceived> 4


No timestamps in xend-debug.log so it's really hard to figure out what
was what.  Network card is an E1000.

> Regards,
> Anthony Liguori
> Mark Williamson wrote:
> >This shouldn't be happening...
> >
> >Could you have a look for clues in your xend.log and xend-debug.log (post 
> >them 
> >to the list if you're having trouble and they're not too long).
> >
> >Is there any chance you have a stale set of tools from another version of 
> >Xen?
> >
> >Cheers,
> >Mark
> >
> >On Wednesday 02 March 2005 22:09, Matt Ayres wrote:
> >  
> >
> >>Hi,
> >>
> >>This is on a 2.0.4 system.  When booting a VM I receive the following on
> >>boot:
> >>
> >>xen_net: Initialising virtual ethernet driver.
> >>xen_net: Failed to connect all virtual interfaces: err=-100
> >>...
> >>NET: Registered protocol family 17
> >>Bridge firewalling registered
> >><hangs>
> >>
> >>I have tried on both 2.4 and 2.6 xenU kernels.
> >>
> >>This seems to have affected all domains... it also prevents them from
> >>being shutdown properly (xm destroy must be used).  Is this a known
> >>issue that is fixed in -testing?
> >>    
> >>
> >
> >

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>