This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Xen "restarting system" on Fedora FC4

To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Xen "restarting system" on Fedora FC4
From: Tony Jones <tony@xxxxxxxxxxx>
Date: Wed, 2 Mar 2005 11:39:03 -0800
Delivery-date: Wed, 02 Mar 2005 19:41:29 +0000
Envelope-to: xen+James.Bulpin@xxxxxxxxxxxx
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.6i
I posted this to the Fedora-test list but I'll try here.

If I need to ditch fedora rpms and move to building directly from src
before posting here, please let me know and I'll do so (apologies in 
advance if this is the case).

I have the following Fedora RPMS installed:

I can boot the main (domain-0) kernel (2.6.10-1.1155_FC4xen0). 
All seems well.

When I try to start domain-1 (which has it's own root and swap partitions)
it starts up and then just reboots without any indication as to why. 

A snippet of the beginning and end of the console output:

# /usr/sbin/xm  create -c dylan-xen1.conf vmid=1
Using config file "dylan-xen1.conf".
Started domain Dylan-dom1, console on port 9606
************ REMOTE CONSOLE: CTRL-] TO QUIT ********
Linux version 2.6.10-1.1155_FC4xenU (bhcompile@xxxxxxxxxxxxxxxxxxxxx) (gcc 
version 3.4.3 20050221 (Red Hat 3.4.3-20)) #1 SMP Sat Feb 26 20:32:34 EST 2005
BIOS-provided physical RAM map:                                          
 Xen: 0000000000000000 - 0000000004000000 (usable)
64MB LOWMEM available.                            
Using x86 segment limits to approximate NX protection
DMI not present.                                     
IRQ lockup detection disabled
Built 1 zonelists            
Kernel command line:  root=/dev/hda2 rw s
Initializing CPU#0                       
PID hash table entries: 1024 (order: 10, 16384 bytes)
Xen reported: 2399.968 MHz processor.                
Using tsc for high-res timesource    
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)  
Memory: 61328k/65536k available (1319k kernel code, 4116k reserved, 477k data, 
128k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 128k freed
Warning: unable to open an initial console.
SELinux:  Disabled at runtime.
SELinux:  Unregistering netfilter hooks
Restarting system.

I get the following in dmesg:
device vif7.0 entered promiscuous mode
xen-br0: port 2(vif7.0) entering learning state
xen-br0: topology change detected, propagating
xen-br0: port 2(vif7.0) entering forwarding state
vif7.0: no IPv6 routers present

At this point the console is non-interruptable (I can leave it for hours) 
until on another window I run an 'xm list' which shows the domain to be 
shutting down.  If I run 'xm list' again there is no entry for the domain and 
at this point I can interrupt the 'xm create' console.

# xm list
Name              Id  Mem(MB)  CPU  State  Time(s)  Console
Domain-0          0      121   0   r----    435.5 
dylan-dom1         4       64   0   ---s-      1.6    9604

The non default aspects of my config are:
kernel = "/boot/vmlinuz-2.6.10-1.1155_FC4xenU"
memory = 64
name = "dylan-dom1"
# hda2 is /   hda6 is swap
disk = [ 'phy:hda2,hda2,w' , 'phy:hda6,hda6,w' ]
root = "/dev/hda2 ro"
extra = "s"
restart = 'never'

Anyone have any clues?



SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list